Wenn der Rechner mal nicht will …

… hilft nur „ruhig Blut“ – No panic. So geschehen diese Tage mit meinem nicht mehr ganz so neuem Lenovo T520 Notebook unter Linux Mint. Eine kleine Geschichte aus dem privaten Computeralltag.

Arbeitsfläche 1_001In den letzten Wochen hatte ich endlich mal wieder Lust und Laune mich privat mit Rechnerkram zu beschäftigen. Das Lenovo-Notebook bekam eine 500 GB SSD verpasst. Mit Clonezilla die Festplatte auf die SSD geklont und … funktioniert. Der Raspberry Pi wurde als Samba-Server eingerichtet und auch mit Owncloud ausgestattet. Auf dem Lenovo-Notebook wurden Virtuelle Maschinen für Win 10 und Win 7 eingerichtet – für meine wenigen Anwendungen die Windows brauchen. Die Windowspartition und die Recoverypartition wurden überflüssig und lagen nun nutzlos rum. Die Linuxpartition ließ sich jedoch nicht vergrößern – warum auch immer.

Die ehemalige Windowspartition war jedoch groß genug für die virtuellen Windowsmaschinen. Also die Partition als ext4-Partition eingerichtet, die Virtuellen Maschinen (VM) dort hin verschoben und die Konfigurationen der VMs angepasst und … läuft. Super! Die kleine Ex-Recoverypartition dient nun als Ablage von ISO-Files und so’m Zeug. Dann noch ein bisschen am Linuxdesktop rumgeschraubt – funktioniert alles wie es soll. Jetzt noch die Sambafreigaben des Raspberry Pi auf dem Notebook richtig einbinden – da hatte ich etwas Probleme – jetzt funktioniert es endlich. Und dann das Notebook gebootet um zu prüfen, dass die Sambafreigaben ordentlich beim Systemstart eingebunden werden … … …

Sch…!! Die SSD bootet nicht mehr!

Was ist denn jetzt los??? Das gibt’s doch nicht. Da läuft alles mal super ohne wirkliche Probleme, das System über mehrere Abende endlich so eingerichtet wie ich es haben will und dann das. Ok! Also erst mal die Kiste beiseite legen und einen langen Spaziergang machen trotz miesen Wetters.

Wieder zuhause – die alte Festplatte eingebaut. Die bootet. Schlussfolgerung: Der Master Boot Record auf der SSD hat nen Schlag. Keine Ahnung warum. Also mal gegoogelt wie man den MBR wieder herstellt. Einen Adapter um eine SATA-Festplatte an USB anzuschließen habe ich. Also die SSD an den USB-Port gehängt … die SSD ist lesbar. Gparted sagt die Partitionen sind ok. Sehr gut. Nach Anleitung den MBR neu installieren. Die Linuxpartition auf der SSD heißt sdb. Also:
sudo grub-install /dev/sdb 
sudo update-grub
Dann die Kiste neu gestartet, die SSD hing noch am USB. Na sowas … das System startet das Linux von der SSD. System runterfahren, Festplatte raus, SSD rein, Rechner starten … läuft. Und die Samba-Freigaben sind auch eingebunden. Alles wieder gut und was gelernt.

Die SSD arbeitet übrigens recht flott, natürlich lautlos und energiesparend. Die Akkulaufzeit hat sich um ca. zwei Stunden verlängert.

image_pdfimage_print

Albert Heller

Ich bin wer ich bin. Mein Motto: Nicht unterkriegen lassen und aus allem das Beste machen. Lieblingszitat: "Zwei Dinge sind unendlich - das Universum und die Dummheit der Menschen. Beim Ersteren bin ich mir aber nicht so sicher." (Albert Einstein)

Kommentare sind geschlossen